<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<title>WebRender newsletter #17 &#8211; Mozilla Gfx Team Blog</title>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Mozilla Gfx Team Blog &raquo; Feed" href="https://mozillagfx.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mozilla Gfx Team Blog &raquo; Comments Feed" href="https://mozillagfx.wordpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mozilla Gfx Team Blog &raquo; WebRender newsletter #17 Comments Feed" href="https://mozillagfx.wordpress.com/2018/04/03/webrender-newsletter-17/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.5-beta1-42868"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJydkE1OAzEMhS+EMa3aig3iLJmMybjNn2KPKm6Pp1GlIiALNtZ78fviOHit4EtWyopphRrXwFkw8oUEz6TV+Qvc3LMXecLf4740svNUnW6JRDM7ipQsNsJSPd2pTS42azjmWi0N01QbiYDVxGsCXWzQkAuUqbE1/pA/2H4l1nVCzjNVspIVzEeWhRrsUfQz0n9Azr7DcFtnuC/PgVRQimcXoT/70XSYMRftzbsY/0aBWLxTLvmbgY/ouI3QRlMswWRASz3YDXpPb7vj/uVwPOxeT+cvWpThyw==?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-1-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJx9i0EKAjEMRS9kDYUZGRfiWTKltpE0KU0Grz+4EBHF1X8f3oNHD0nFszi0LXTeCokBJieVFcebjsnsAL/1rubhxkgDrOIgKa/9V5kmQg6sRT/PV+Q1t2xQJyisK/JTuLZLnOPpvMxxWu47xX5JvA==?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1522184747h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mozillagfx.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='WebRender newsletter #16' href='https://mozillagfx.wordpress.com/2018/03/19/webrender-newsletter-16/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://mozillagfx.wordpress.com/2018/04/03/webrender-newsletter-17/" />
<link rel='shortlink' href='https://wp.me/p2I6YD-h5' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F04%2F03%2Fwebrender-newsletter-17%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F04%2F03%2Fwebrender-newsletter-17%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="WebRender newsletter #17" />
<meta property="og:url" content="https://mozillagfx.wordpress.com/2018/04/03/webrender-newsletter-17/" />
<meta property="og:description" content="Bonsoir ! WebRender&#8217;s seventeenth newsletter is here. The biggest highlight of this couple of weeks is without hesitation the landing of Jeff&#8217;s blob image invalidation work. Months of h…" />
<meta property="article:published_time" content="2018-04-03T16:32:22+00:00" />
<meta property="article:modified_time" content="2018-04-03T16:32:22+00:00" />
<meta property="og:site_name" content="Mozilla Gfx Team Blog" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="WebRender newsletter #17" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s1.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s2.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://mozillagfx.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://mozillagfx.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://mozillagfx.wordpress.com/osd.xml" title="Mozilla Gfx Team Blog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="Mozilla Gfx Team Blog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://mozillagfx.wordpress.com/feed/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="title" content="WebRender newsletter #17 | Mozilla Gfx Team Blog on WordPress.com" />
<meta name="description" content="Bonsoir ! WebRender&#039;s seventeenth newsletter is here. The biggest highlight of this couple of weeks is without hesitation the landing of Jeff&#039;s blob image invalidation work. Months of hard work went into what grew into a reimplementation of a decent portion of FrameLayerBuilder for blob images and will improve SVG rendering performance quite a bit&hellip;" />
<link rel="amphtml" href="https://mozillagfx.wordpress.com/2018/04/03/webrender-newsletter-17/amp/"><style type="text/css" id="syntaxhighlighteranchor"></style>
</head>

<body class="post-template-default single single-post postid-1059 single-format-standard wp-custom-logo mp6 customizer-styles-applied group-blog highlander-enabled highlander-light">

<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div id="hero-header" class="site-hero-section">
		<header id="masthead" class="site-header" role="banner">
			<div class="inner">
				<div class="site-branding">
					<a href="https://mozillagfx.wordpress.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="388" height="388" src="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png" class="custom-logo" alt="&quot;Glitched&quot; Firefox nightly logo" itemprop="logo" srcset="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png 388w, https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=150&amp;h=150 150w, https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=300&amp;h=300 300w" sizes="(max-width: 388px) 100vw, 388px" data-attachment-id="238" data-permalink="https://mozillagfx.wordpress.com/nightly-glitch03/" data-orig-file="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png" data-orig-size="388,388" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Firefox nightly (glitch)" data-image-description="" data-medium-file="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=300" data-large-file="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=388" /></a>
												<p class="site-title"><a href="https://mozillagfx.wordpress.com/" rel="home">Mozilla Gfx Team Blog</a></p>
										</div><!-- .site-branding -->

				
				
			</div><!-- .inner -->
		</header><!-- #masthead -->
	</div>

		
	
	
	<div id="content-wrapper" class="content-wrapper">
		<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-1059" class="post-1059 post type-post status-publish format-standard hentry category-wr-newsletter">
			<header class="entry-header">
			<h1 class="entry-title">WebRender newsletter #17</h1>		</header><!-- .entry-header -->		<div class="entry-meta">
			<span class="byline">
				<a href="https://mozillagfx.wordpress.com/author/nicalsilva/" title="Posts by Nical" rel="author">Nical</a>			</span>
							<span class="cat-links">
					<a href="https://mozillagfx.wordpress.com/category/wr-newsletter/" rel="category tag">wr-newsletter</a>				</span><!-- .cat-links -->
			
			
			<span class="published-on">
				<time class="entry-date published updated" datetime="2018-04-03T16:32:22+00:00">April 3, 2018</time>			</span>

			<span class="word-count">2 Minutes</span>		</div><!-- .entry-meta -->
	
	<div class="entry-content">
		<p>Bonsoir ! WebRender&#8217;s seventeenth newsletter is here. The biggest highlight of this couple of weeks is without hesitation the landing of Jeff&#8217;s blob image invalidation work. Months of hard work went into what grew into a reimplementation of a decent portion of <a href="https://searchfox.org/mozilla-central/source/layout/painting/FrameLayerBuilder.cpp">FrameLayerBuilder</a> for blob images and will improve SVG rendering performance quite a bit in WebRender as soon as it will be enabled by default. See the first item in the list of Gecko changes for more details.</p>
<h2>Notable WebRender changes</h2>
<ul>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2601">fixed</a> a shadow clipping bug.</li>
<li>fschutt <a href="https://github.com/servo/webrender/pull/2574">made</a> compiling the debug render shaders optional to improve startup time.</li>
<li>Josh <a href="https://github.com/servo/webrender/pull/2594">updated</a> the freetype dependency.</li>
<li>Botond <a href="https://github.com/servo/webrender/pull/2585/files">implemented</a> taking backface-visibility into account during hit-testing.</li>
<li>Kvark <a href="https://github.com/servo/webrender/pull/2582">improved</a> teh frame capture tool.</li>
<li>Martin <a href="https://github.com/servo/webrender/pull/2578">fixed</a> a border clipping issue.</li>
<li>Simon <a href="https://github.com/servo/webrender/pull/2577">updated</a> serde.</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2556">unified</a> the text-shadow and blur filter implementation.</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2563">implemented</a> handling box shadow stretch modes per-axis to avoid allocating huge render tasks for very long/thin elements.</li>
<li>Kvark <a href="https://github.com/servo/webrender/pull/2569">prevented</a> incorrectly reusing frame ids from previous frames in render tasks.</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2555">made</a> mipmap generation optional (it can be very slow and it is on the critical path so we are better off downscaling on the image decoder side).</li>
<li>Nical <a href="https://github.com/servo/webrender/pull/2568">fixed</a> a bug causing elements to disappear under certain conditions.</li>
<li>Martin <a href="https://github.com/servo/webrender/pull/2559">added</a> hit-testing support in wrench.</li>
<li>fschutt <a href="https://github.com/servo/webrender/pull/2565">sped up</a> allocating images in wrench.</li>
<li>Nical <a href="https://github.com/servo/webrender/pull/2410">removed</a> an old scrolling workaround in wrench made unnecessary by the transaction API.</li>
<li>Sotaro <a href="https://github.com/servo/webrender/pull/2558">fixed</a> the way TEXTURE_RECT sampling is handled in the shader (important for some video code paths).</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2552">removed</a> the brush line shader and converted line decorations to use clip sources (fixes some edge cases and improves batching).</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2540">implemented</a> rendering text shadows in screen space.</li>
<li>TyOverby and Kats <a href="https://github.com/servo/webrender/pull/2547">updated</a> the bincode dependency.</li>
</ul>
<h2>Notable Gecko changes</h2>
<ul>
<li>Jeff <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1388842">landed</a> blob image invalidation.
<p>This gives us the ability to do proper invalidation and layerization for inline SVG with blob images. For example, the animation on <a href="http://snapsvg.io/demos/#game" rel="nofollow">http://snapsvg.io/demos/#game</a> can now run asynchronously. It also means that we further avoid some the performance problems that FrameLayerBuilder has (<a href="https://airtable.com/shrRydo6UXhebLShj/tblc2X4kICL8NGzG5">this site</a> runs much better with blob invalidation, and <a href="https://www1.ticketmaster.com/angels-in-america-ny-parts-1-new-york-new-york-04-05-2018/event/0300533BA19F3A85?artistid=2419828&amp;majorcatid=10002&amp;minorcatid=32&amp;tm_link=artist_msg-0_0300533BA19F3A85">this site</a> as well for example).</p>
</li>
<li>
<p>Sotaro <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1191971">implemented</a> presenting through direct composition in some cases.</p>
</li>
<li>Sotaro <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1411481">enabled</a> skia-gl canvas on Mac.</li>
<li>Sotaro <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1413392">enabled</a> D2D canvas on Windows.</li>
<li>Kats <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1423370">reduced</a> the number of WebRenderScrollLayerData item created for transformed items (perf improvement) and <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1449478">fixed</a> a followup bug.</li>
<li>Kats <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1425589">enabled</a> more tests.</li>
<li>Sotaro <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1432261">fixed</a> a rendering bug when ANGLE is disabled on Windows.</li>
<li>Andrew <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1433351">fixed</a> an intermittent crash happening under memory pressure.</li>
<li>Martin <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1444904">fixed</a> a hit-testing bug with fixed-position elements.</li>
<li>Jeff <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1447076">fixed</a> a crash with zero-sized blob images.</li>
<li>Jeff <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1446588">fixed</a> another crash.</li>
<li>Lee <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1447910">fixed</a> a crash related to the memory management of fonts.</li>
<li>Kats <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1448006">disabled</a> WebRender-side mipmap generation.</li>
<li>Kats <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1448086">disabled</a> QR tests on beta since WebRender isn&#8217;t available there yet.</li>
<li>Kats <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1448993">ensured</a> crash reports properly tell whether WebRender is enabled.</li>
<li>Nical <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1449242">improved</a> the memory management of images.</li>
<li>Jeff <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1449640">avoided</a> computing a scale for 3d-transformed elements. and <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1449958">fixed</a> a followup bug.</li>
<li>Jeff <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1450346">fixed</a> uninitialized app-units-per-dev-pixels scale factor.</li>
</ul>
<h2>Enabling WebRender in Firefox Nightly</h2>
<p>In about:config, just set “gfx.webrender.all” to true and restart the browser. No need to toggle any other pref.</p>
<p>Note that WebRender can only be enabled in Firefox Nightly. We will make it possible to enable it on other release channels as soon as we consider it stable enough to reach a broader audience.</p>
<h2>Reporting bugs</h2>
<p>The best place to report bugs related to WebRender in Gecko is the <a href="https://bugzilla.mozilla.org/enter_bug.cgi?product=Core&amp;component=Graphics%3A%20WebRender">Graphics :: WebRender component in bugzilla</a>. It is possible to log in with a github account.</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-1059" class="share-twitter sd-button share-icon" href="https://mozillagfx.wordpress.com/2018/04/03/webrender-newsletter-17/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-1059" class="share-facebook sd-button share-icon" href="https://mozillagfx.wordpress.com/2018/04/03/webrender-newsletter-17/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-40065927-1059-5ac3babf8d998' data-src='//widgets.wp.com/likes/index.html?ver=20180319#blog_id=40065927&amp;post_id=1059&amp;origin=mozillagfx.wordpress.com&amp;obj_id=40065927-1059-5ac3babf8d998' data-name='like-post-frame-40065927-1059-5ac3babf8d998'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>	</div><!-- .entry-content -->

	<div class="entry-footer">
			</div><!-- .entry-footer -->

	<div class="entry-author-wrapper">
			<div class="entry-author author-avatar-show">
				<div class="author-avatar">
			<img alt='' src='https://1.gravatar.com/avatar/110ed13acdbaeab2c6ba38f76e0fedf2?s=80&#038;d=identicon&#038;r=G' class='avatar avatar-80' height='80' width='80' />		</div><!-- .author-avatar -->
		
		<div class="author-heading">
			<h2 class="author-title">Published by <span class="author-name">Nical</span></h2>
		</div><!-- .author-heading -->

		<p class="author-bio">
						<a class="author-link" href="https://mozillagfx.wordpress.com/author/nicalsilva/" rel="author">
				View all posts by Nical			</a>
		</p><!-- .author-bio -->
	</div><!-- .entry-auhtor -->
		<div class="site-posted-on">
			<strong>Published</strong>
			<time class="entry-date published updated" datetime="2018-04-03T16:32:22+00:00">April 3, 2018</time>		</div><!-- .site-posted-on -->
	</div>
</article><!-- #post-## -->

			
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://mozillagfx.wordpress.com/2018/03/19/webrender-newsletter-16/" rel="prev"><span class="meta-nav screen-reader-text">Previous Post</span> WebRender newsletter #16</a></div></div>
	</nav>
			
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/04/03/webrender-newsletter-17/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://mozillagfx.wordpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="e1dfe92e18" /><input type="hidden" name="_wp_http_referer" value="/2018/04/03/webrender-newsletter-17/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<iframe id="googleplus-sign-in" name="googleplus-sign-in" src="https://public-api.wordpress.com/connect/?googleplus-sign-in=https%3A%2F%2Fmozillagfx.wordpress.com&#038;color_scheme=light" width="24" height="24" scrolling="no" allowtransparency="true" seamless="seamless" frameborder="0"></iframe>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google+ account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
		w
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1059' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="57d2d21898" /></p>
<input type="hidden" name="genseq" value="1522776767" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="62"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

		</div><!-- #content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
						<div class="site-info">
				<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
				
							</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #content-wrapper -->
</div><!-- #page -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201814y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-110ed13acdbaeab2c6ba38f76e0fedf2">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/mozillagfx.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/mozillagfx.wordpress.com\/wp-login.php?action=logout&_wpnonce=63bfa5fd75","homeURL":"https:\/\/mozillagfx.wordpress.com\/","postID":"1059","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1521806916j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/mozillagfx.wordpress.com\/2018\/04\/03\/webrender-newsletter-17\/":1059};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
		<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"40065927","siteName":"Mozilla Gfx Team Blog","siteURL":"http:\/\/mozillagfx.wordpress.com","icon":"<img alt='' src='https:\/\/s2.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/independent-publisher-2","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/mozillagfx.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F04%2F03%2Fwebrender-newsletter-17%2F","themeURL":"https:\/\/wordpress.com\/theme\/independent-publisher-2\/","xhrURL":"https:\/\/mozillagfx.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"39c3c24343","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"45d71fe78e\" \/>","referer":"https:\/\/mozillagfx.wordpress.com\/2018\/04\/03\/webrender-newsletter-17\/","canFollow":"1","feedID":"4421974","statusMessage":"","customizeLink":"https:\/\/mozillagfx.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F04%2F03%2Fwebrender-newsletter-17%2F","postID":"1059","shortlink":"https:\/\/wp.me\/p2I6YD-h5","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/mozillagfx.wordpress.com\/1059","statsLink":"https:\/\/wordpress.com\/stats\/post\/1059\/mozillagfx.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Independent Publisher 2","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 58 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/mozillagfx.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F04%2F03%2Fwebrender-newsletter-17%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJydUVtOxDAMvBBulq5Y+EEcBWUTt3Wb19pJF25P8kGFkKhEf+LXzPgRdU9gYsgYsppFWVzJYProZnlQP0q+QHJlpCDK0YKibgULTjpYh/wbnCf0FZLKVVGwmLA+IUONHcmEDH1rFfRKo84UwzH+H6VjYrJQAkdhgSGaIjDQdgIKxhVbJSrMRO8bmzG5z87TkdGrnhLDlDLcUxXcObW2tQVcNSuvJSNXD+KKzNTm2XL/VMiszSJ7JNN+pZE2bw+9kHjMcO5O6r0tN0TeWypFyTA4Taxk0kxh/LaV9OZfH5/6/nI5nV+e5y93qfma'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20180319#ver=20180319' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'40065927','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'40065927','v':'wpcom','tz':'0','user_id':'0','post':'1059','subd':'mozillagfx'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5U1JMLU8/MkNtblkvY1dldi1Cdz1FW1N6S0NteFFsTTZdcCVqdmgvLFhfenh5LDhvTmx3RWZoQ29YRjVJWm89LW42X3ZoTjVPWElVN2FQbUYsel9lY1BELi5mQV0zflUsW1hxaktGbUxISn4mNmVHXUlrVS1yZ3JuLHpJOERXbW9JP2ZqPzNiaXVhMitvbmNJTUNkbXdTfmY3R110MT8wSnEmWzVUYzhuVTBGK2NKUTRjRmlVJWRsY0wrNE5HTlEtN25yVzRKSV0rPWxqaT1wbHNBbE1XRQ=='}]);
_stq.push([ 'clickTrackerInit', '40065927', '1059' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
<!--
	generated in 0.083 seconds
	48921 bytes batcached for 300 seconds
-->
