<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">

<title>WebRender newsletter #12 &#8211; Mozilla Gfx Team Blog</title>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Mozilla Gfx Team Blog &raquo; Feed" href="https://mozillagfx.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mozilla Gfx Team Blog &raquo; Comments Feed" href="https://mozillagfx.wordpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mozilla Gfx Team Blog &raquo; WebRender newsletter #12 Comments Feed" href="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.9.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJydkN1OwzAMhV8IY9i0Sb1APEuamtZb/hS7mvb2uIsmbQJywY11Tny+OA5eCviclJJiXKGEdeYkGPhMgifS4vwZbu7Vi7zg73GfK9l5LE63RKSJHQWKFuthsRzv1CYXm9UdcymWhnEslUTAauQ1gi42qMvNlKiyNf6QP9h2JZZ1RE4TFbKSFMwHloUq7FD0Gug/ICffYLit092Xp5lUULJnF6A9+9E0mDFlbc276P9GhpC9U87pycBXcFx7aKUx5NnkjJZ6sBv0GT/eD2/Dfj8cht3pG1rb4dU=?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-1-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mozillagfx.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Retained Display Lists' href='https://mozillagfx.wordpress.com/2018/01/09/retained-display-lists/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/" />
<link rel='shortlink' href='https://wp.me/p2I6YD-gM' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F01%2F16%2Fwebrender-newsletter-12%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F01%2F16%2Fwebrender-newsletter-12%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="WebRender newsletter #12" />
<meta property="og:url" content="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/" />
<meta property="og:description" content="Hi there, your 12th WebRender newsletter has arrived. As I mentioned in the previous newsletter, the biggest theme in the last two weeks has been fixing correctness bugs and adding missing features…" />
<meta property="article:published_time" content="2018-01-16T17:56:23+00:00" />
<meta property="article:modified_time" content="2018-01-16T19:50:04+00:00" />
<meta property="og:site_name" content="Mozilla Gfx Team Blog" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@wordpressdotcom" />
<meta name="twitter:text:title" content="WebRender newsletter #12" />
<meta name="twitter:card" content="summary" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s0.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://mozillagfx.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://mozillagfx.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://mozillagfx.wordpress.com/osd.xml" title="Mozilla Gfx Team Blog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="Mozilla Gfx Team Blog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://mozillagfx.wordpress.com/feed/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="WebRender newsletter #12 | Mozilla Gfx Team Blog on WordPress.com" />
<meta name="description" content="Hi there, your 12th WebRender newsletter has arrived. As I mentioned in the previous newsletter, the biggest theme in the last two weeks has been fixing correctness bugs and adding missing features. I keep learning new and scary things about text while Lee digs up more and more features that we need to add support&hellip;" />
<link rel="amphtml" href="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
</head>

<body class="post-template-default single single-post postid-1040 single-format-standard wp-custom-logo mp6 customizer-styles-applied group-blog highlander-enabled highlander-light">

<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<div id="hero-header" class="site-hero-section">
		<header id="masthead" class="site-header" role="banner">
			<div class="inner">
				<div class="site-branding">
					<a href="https://mozillagfx.wordpress.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="388" height="388" src="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png" class="custom-logo" alt="&quot;Glitched&quot; Firefox nightly logo" itemprop="logo" srcset="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png 388w, https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=150&amp;h=150 150w, https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=300&amp;h=300 300w" sizes="(max-width: 388px) 100vw, 388px" data-attachment-id="238" data-permalink="https://mozillagfx.wordpress.com/nightly-glitch03/" data-orig-file="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png" data-orig-size="388,388" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Firefox nightly (glitch)" data-image-description="" data-medium-file="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=300" data-large-file="https://mozillagfx.files.wordpress.com/2017/08/nightly-glitch03.png?w=388" /></a>
												<p class="site-title"><a href="https://mozillagfx.wordpress.com/" rel="home">Mozilla Gfx Team Blog</a></p>
										</div><!-- .site-branding -->

				
				
			</div><!-- .inner -->
		</header><!-- #masthead -->
	</div>

		
	
	
	<div id="content-wrapper" class="content-wrapper">
		<div id="content" class="site-content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-1040" class="post-1040 post type-post status-publish format-standard hentry category-wr-newsletter">
			<header class="entry-header">
			<h1 class="entry-title">WebRender newsletter #12</h1>		</header><!-- .entry-header -->		<div class="entry-meta">
			<span class="byline">
				<a href="https://mozillagfx.wordpress.com/author/nicalsilva/" title="Posts by Nical" rel="author">Nical</a>			</span>
							<span class="cat-links">
					<a href="https://mozillagfx.wordpress.com/category/wr-newsletter/" rel="category tag">wr-newsletter</a>				</span><!-- .cat-links -->
			
			
			<span class="published-on">
				<time class="entry-date published" datetime="2018-01-16T17:56:23+00:00">January 16, 2018</time><time class="updated" datetime="2018-01-16T19:50:04+00:00">January 16, 2018</time>			</span>

			<span class="word-count">2 Minutes</span>		</div><!-- .entry-meta -->
	
	<div class="entry-content">
		<p>Hi there, your 12th WebRender newsletter has arrived. As I mentioned in the previous newsletter, the biggest theme in the last two weeks has been fixing correctness bugs and adding missing features. I keep learning new and scary things about text while Lee digs up more and more features that we need to add support for.<br />
If you are testing on Windows and WebRender makes rendering flicker horribly, worry not Kvark has landed a fix in WebRender that will make it in nightly soon.</p>
<h2>Notable WebRender changes</h2>
<ul>
<li>Glenn is making progress <a href="https://github.com/servo/webrender/pull/2271">(1)</a>,<a href="https://github.com/servo/webrender/pull/2259">(2)</a> in the conversion to segmented primitives which lets us move more content to the opaque pass and improves batching.</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2043">removed</a> the need to re-build the scene when a dynamic property changes. This saves a lot of CPU time during scrolling and animations.</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2284">added</a> support for caching render tasks across frames and display lists, and added support for it in box shadows. This nice because it will let us avoid re-doing some of the same potentially expensive things every frame (like blurs). </li>
<li>Morris fixed a drop-shadow rendering issues (<a href="https://github.com/servo/webrender/pull/2243">#2243</a> and <a href="https://github.com/servo/webrender/pull/2261">#2261</a>).</li>
<li>Lee fixed/implemented various text rendering features <a href="https://github.com/servo/webrender/pull/2262">(1)</a> <a href="https://github.com/servo/webrender/pull/2245">(2)</a>.</li>
<li>Kvark <a href="https://github.com/servo/webrender/pull2254">fixed</a> edge mask decoding in the shaders.</li>
<li>Martin fixed/improved the clipping logic <a href="https://github.com/servo/webrender/pull/2249">(1)</a> <a href="https://github.com/servo/webrender/pull/2200">(2)</a> <a href="https://github.com/servo/webrender/pull/2205">(3)</a>.</li>
<li>Nical <a href="https://github.com/servo/webrender/pull/1963">added</a> the concept of transactions to the API (allows us to express certain constraints important for correctness and avoid redundant work).</li>
<li>Ethan <a href="https://github.com/servo/webrender/pull/2307">fixed</a> some glitches when box-shadow parameters are close to zero. </li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2304">switched</a> travis off for mac builds, we are now using taskcluster. Travis is great but it couldn&#8217;t sustain the load on Mac. Testing turnaround times are going to be much better now!</li>
<li>Kats <a href="https://github.com/servo/webrender/pull/2295">resurrected</a> support for non-premultiplied images (We need it for canvas). </li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2301">ported</a> line primitives to the brush infrastructure.</li>
<li>Martin <a href="https://github.com/servo/webrender/pull/2300">implemented</a> a more expressive API for clipping.</li>
<li>Ethan <a href="https://github.com/servo/webrender/pull/2292">fixed</a> a glitch when mixing edges with and without borders.</li>
<li>Lee <a href="https://github.com/servo/webrender/pull/2288">implemented</a> support for glyph transforms for writing modes.</li>
<li>Markus <a href="https://github.com/servo/webrender/pull/2286">fixed</a> a bug in the calculation of corner radius overlap.</li>
<li>Ethan <a href="https://github.com/servo/webrender/pull/2285">fixed</a> a bug in with inset box-shadow offsets.</li>
<li>Glenn <a href="https://github.com/servo/webrender/pull/2276">moved</a> alpha targets from using the A8 format to R8 on all platforms which avoids slow paths on ANGLE and some drivers.</li>
</ul>
<h2>Notable Gecko changes</h2>
<ul>
<li>Lee <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1394568">implemented</a> the plumbing for synthetic italic.</li>
<li>Nical <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1425453">updated</a> the gecko integration to use the transaction API and take advantage of it.</li>
<li>Nical <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1405824">implemented</a> a simple shared memory recycling scheme for blob images and fonts (improves the performance of display list building).</li>
<li>Gankro <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1429577">fixed</a> sub-pixel aa for some bullet display items.</li>
<li>Andrew <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1428013">fixed</a> a bug causing images to disappear after dragging a tab to a different  window.</li>
<li>Kats <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1422057">sped up</a> display list building by removing duplicated work for adjacent items with equivalent clip chains.</li>
<li>Ethan <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1424673">fixed</a> a text rendering issue.</li>
<li>Milan <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1425260">added</a> the &#8220;gfx.webrender.all&#8221; pref to simplify enabling the most up to date WebRender prefs on all platforms.</li>
<li>Sotaro <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1424747">fixed</a> a memory leak and a lot of smaller things (too many for me to link them here).</li>
<li>Vincent and Jerry <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=1418999">fixed</a> a bug with video on unfocused tabs freezing.</li>
</ul>
<h2>Enabling WebRender in Firefox Nightly</h2>
<p>In about:config:<br />
&#8211; just set “gfx.webrender.all” to true (no other prefs needed anymore \o/)</p>
<p>Note that WebRender can only be enabled in Firefox Nightly.</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-1040" class="share-twitter sd-button share-icon" href="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-1040" class="share-facebook sd-button share-icon" href="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-40065927-1040-5a5eca4e3eed8' data-src='//widgets.wp.com/likes/#blog_id=40065927&amp;post_id=1040&amp;origin=mozillagfx.wordpress.com&amp;obj_id=40065927-1040-5a5eca4e3eed8' data-name='like-post-frame-40065927-1040-5a5eca4e3eed8'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>	</div><!-- .entry-content -->

	<div class="entry-footer">
			</div><!-- .entry-footer -->

	<div class="entry-author-wrapper">
			<div class="entry-author author-avatar-show">
				<div class="author-avatar">
			<img alt='' src='https://1.gravatar.com/avatar/110ed13acdbaeab2c6ba38f76e0fedf2?s=80&#038;d=identicon&#038;r=G' class='avatar avatar-80' height='80' width='80' />		</div><!-- .author-avatar -->
		
		<div class="author-heading">
			<h2 class="author-title">Published by <span class="author-name">Nical</span></h2>
		</div><!-- .author-heading -->

		<p class="author-bio">
						<a class="author-link" href="https://mozillagfx.wordpress.com/author/nicalsilva/" rel="author">
				View all posts by Nical			</a>
		</p><!-- .author-bio -->
	</div><!-- .entry-auhtor -->
		<div class="site-posted-on">
			<strong>Published</strong>
			<time class="entry-date published" datetime="2018-01-16T17:56:23+00:00">January 16, 2018</time><time class="updated" datetime="2018-01-16T19:50:04+00:00">January 16, 2018</time>		</div><!-- .site-posted-on -->
	</div>
</article><!-- #post-## -->

			
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://mozillagfx.wordpress.com/2018/01/09/retained-display-lists/" rel="prev"><span class="meta-nav screen-reader-text">Previous Post</span> Retained Display Lists</a></div></div>
	</nav>
			
<div id="comments" class="comments-area">

	
			<h2 class="comments-title">
			2 thoughts on &ldquo;<span>WebRender newsletter #12</span>&rdquo;		</h2><!-- .comments-title -->

		
		<ol class="comment-list">
					<li id="comment-1733" class="comment even thread-even depth-1 parent highlander-comment">
			<article id="div-comment-1733" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://2.gravatar.com/avatar/e8eaa95be05e7aefc8cef8b073210fd1?s=48&#038;d=identicon&#038;r=G' class='avatar avatar-48' height='48' width='48' />						<b class="fn">Dan W</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/#comment-1733">
							<time datetime="2018-01-16T21:36:07+00:00">
								January 16, 2018 at 9:36 pm							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Do you want Nightly users to enable WebRender in order to get more bug reports, or is there enough low-hanging fruit that that wouldn&#8217;t be particularly helpful?</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/?replytocom=1733#respond' onclick='return addComment.moveForm( "div-comment-1733", "1733", "respond", "1040" )' aria-label='Reply to Dan W'>Reply</a></div>			</article><!-- .comment-body -->
<ol class="children">
		<li id="comment-1734" class="comment odd alt depth-2 highlander-comment">
			<article id="div-comment-1734" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://1.gravatar.com/avatar/47977caadeb53f4ee7067f9f711c085a?s=48&#038;d=identicon&#038;r=G' class='avatar avatar-48' height='48' width='48' />						<b class="fn">HackedByRussia</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/#comment-1734">
							<time datetime="2018-01-17T01:56:27+00:00">
								January 17, 2018 at 1:56 am							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>REPORT ALL THE BUGS!#%!!11 As long as they aren&#8217;t dupes! (;</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://mozillagfx.wordpress.com/2018/01/16/webrender-newsletter-12/?replytocom=1734#respond' onclick='return addComment.moveForm( "div-comment-1734", "1734", "respond", "1040" )' aria-label='Reply to HackedByRussia'>Reply</a></div>			</article><!-- .comment-body -->
</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

		
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/01/16/webrender-newsletter-12/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://mozillagfx.wordpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="1b160d8479" /><input type="hidden" name="_wp_http_referer" value="/2018/01/16/webrender-newsletter-12/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
			<iframe id="googleplus-sign-in" name="googleplus-sign-in" src="https://public-api.wordpress.com/connect/?googleplus-sign-in=https%3A%2F%2Fmozillagfx.wordpress.com" width="24" height="24" scrolling="no" allowtransparency="true" seamless="seamless" frameborder="0"></iframe>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1040' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8fd8428145" /></p>
<input type="hidden" name="genseq" value="1516161614" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="82"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

		</div><!-- #content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
						<div class="site-info">
				<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a>
				
							</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #content-wrapper -->
</div><!-- #page -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201803y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-110ed13acdbaeab2c6ba38f76e0fedf2">
	</div>
	<div class="grofile-hash-map-e8eaa95be05e7aefc8cef8b073210fd1">
	</div>
	<div class="grofile-hash-map-47977caadeb53f4ee7067f9f711c085a">
	</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/mozillagfx.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/mozillagfx.wordpress.com\/wp-login.php?action=logout&_wpnonce=a4170c9624","homeURL":"https:\/\/mozillagfx.wordpress.com\/","postID":"1040","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/mozillagfx.wordpress.com\/2018\/01\/16\/webrender-newsletter-12\/":1040};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
		<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"40065927","siteName":"Mozilla Gfx Team Blog","siteURL":"http:\/\/mozillagfx.wordpress.com","icon":"<img alt='' src='https:\/\/s1.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/independent-publisher-2","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/mozillagfx.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F01%2F16%2Fwebrender-newsletter-12%2F","themeURL":"https:\/\/wordpress.com\/theme\/independent-publisher-2\/","xhrURL":"https:\/\/mozillagfx.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"a754339bf7","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"913f118789\" \/>","referer":"https:\/\/mozillagfx.wordpress.com\/2018\/01\/16\/webrender-newsletter-12\/","canFollow":"1","feedID":"4421974","statusMessage":"","customizeLink":"https:\/\/mozillagfx.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F01%2F16%2Fwebrender-newsletter-12%2F","postID":"1040","shortlink":"https:\/\/wp.me\/p2I6YD-gM","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/mozillagfx.wordpress.com\/1040","statsLink":"https:\/\/wordpress.com\/stats\/post\/1040\/mozillagfx.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Independent Publisher 2","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 50 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/mozillagfx.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fmozillagfx.wordpress.com%2F2018%2F01%2F16%2Fwebrender-newsletter-12%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJydUVtOxDAMvBBeb1ktEh+Io6Bs6rZu88JOunB7kg8qhEQl+hO/ZsaP4D2BjSFTyDgr9rSypfRxmvUBf5R8geTKyEHR8UKK74UKTSb0juQ3OE/kKySVG3LoKVF9QoYaO9aJBB5bq2BWHk3mGI7x/ygdE9OFEzgOCwzRFoWBtxNwsK70VaLCbPS+sYWS+zx5PjJ61UO1winDPVXBnVObvraAmxH0RjNJ9SCuJMJtni33T4Usxi66R7LtVxpp8/bQC6unDJfTGd/ackOUvaVS1AyDMyyokxEO47etpFf/0l27p647X56v8xd3fvmS'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'40065927','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'40065927','v':'wpcom','tz':'0','user_id':'0','post':'1040','subd':'mozillagfx'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5U1JMLU8/MkNtblkvY1dldi1Cdz1FW1N6S0NteFFsTTZdcCVqdmgvLFhfenh5LDhvTmx3RWZoQ29YRjVJWm89LW42X3ZoTjVPWElVN2FQbUYsel9lY1BufHxlcEVfRExDTnpPMGkuYj05ZUYwLHJDcCZySU12T1hYbC8wcEEmWTkyZHlmSTg3ZEFwc3BweE1mQjBXOSxoaGdkdHIweWJwcHlOb2NFOTl3Ui9fdiVoMk04OC9YckZyamhsUDRhVDhsVFJDWX49byVIZFJFLkw5aGJMem8x'}]);
_stq.push([ 'clickTrackerInit', '40065927', '1040' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
<!--
	generated 191 seconds ago
	generated in 0.093 seconds
	served from batcache in 0.001 seconds
	expires in 109 seconds
-->
